privy - Partially degraded email deliverability – Incident details

Partially degraded email deliverability

Resolved
Degraded performance
Started 10 days agoLasted about 18 hours

Affected

3rd Party Services

Degraded performance from 2:30 AM to 8:45 PM

Email Auth

Degraded performance from 2:30 AM to 8:45 PM

Updates
  • Resolved
    Resolved

    This incident with SendGrid deliverability has been resolved. Only iCloud (<2-3% of emails) were impacted.

  • Monitoring
    Monitoring

    We are working with SendGrid on a fix. OTP email deliverability, primarily for iCloud emails (<2-3% of emails) are still impacted.

  • Investigating
    Investigating

    We are currently investigating an incident impacting Email OTP codes with SendGrid.