privy - Email deliverability delays with google.com domains – Incident details

Email deliverability delays with google.com domains

Resolved
Degraded performance
Started about 2 months agoLasted about 2 hours

Affected

3rd Party Services

Degraded performance from 4:30 PM to 6:01 PM, Operational from 6:01 PM to 6:02 PM

Third Party: Google Workspace → Gmail

Degraded performance from 4:30 PM to 6:01 PM, Operational from 6:01 PM to 6:02 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We've observed a reduction in reports of delayed emails to google.com inboxes. We'll continue to monitor deliverability.

  • Investigating
    Investigating

    We have identified email deliverability delays with google.com domains. Google is experiencing degraded performance at the moment.

    We are continuing to work on how to mitigate and address this incident.