privy - X (fka Twitter) API experiencing outage – Incident details

X (fka Twitter) API experiencing outage

Resolved
Partial outage
Started 2 months agoLasted about 10 hours

Affected

3rd Party Services

Partial outage from 7:00 AM to 3:24 PM, Operational from 3:24 PM to 4:44 PM

OAuth: Google, Twitter, Discord, Github, Apple, Instagram

Partial outage from 7:00 AM to 3:24 PM, Operational from 3:24 PM to 4:44 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Monitoring
    UTC
    Monitoring

    The X API (both OAuth 2.0 and 1.0a) appears to be functional. We are continuing to monitor this service.

  • Investigating
    UTC
    Investigating

    The X (formerly Twitter) API is experiencing issues. Users attempting to sign in with X may see an ERR_TOO_MANY_REDIRECTS error.

    This appears to be an undocumented X API outage affecting OAuth 2.0. X developers report that OAuth 1.0a is still functional. As a workaround, you can set up OAuth 1.0a by creating an X Developer account and adding your X API OAuth 1.0a credentials to the Privy dashboard. Detailed instructions are available here: https://docs.privy.io/basics/get-started/dashboard/configure-login-methods#oauth-login-methods-google-twitter-etc:x-formerly-known-as-twitter:oauth-1-0a-for-twitter