privy - Delays and deliverability issues to certain email providers – Incident details

Delays and deliverability issues to certain email providers

Resolved
Operational
Started about 1 month agoLasted 2 days

Affected

Core Services

Degraded performance from 6:04 PM to 3:06 PM

Email Auth

Degraded performance from 6:04 PM to 3:06 PM

Updates
  • Resolved
    Resolved

    Email deliverability in Outlook has returned to expected levels. Please reach out to [email protected] if you continue to experience issues.

  • Monitoring
    Monitoring

    A large spike in low quality email addresses caused temporary issues with deliverability in some email providers with passwordless email auth. We have filtered out the bad requests and have seen email deliverability largely return to normal with the exception of outlook-based addresses in particular. We will continue to monitor the situation.

  • Investigating
    Investigating

    We have identified an issue with email deliverability with certain email providers. We are working to mitigate the issue.