privy - Degraded performance on batch users endpoint – Incident details

Degraded performance on batch users endpoint

Resolved
Degraded performance
Started 19 days agoLasted about 3 hours

Affected

APIs

Degraded performance from 10:08 AM to 1:08 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    A database change caused our batch fetching of users to slow down. Fetching user details by ID was not affected. A fix has been deployed and we are monitoring.

  • Investigating
    Investigating

    We are currently investigating an issue causing high latency on our batch users endpoint (GET /api/v1/users)